Paint Talk - Professional Painting Contractors Forum

Paint Talk - Professional Painting Contractors Forum (https://www.painttalk.com/)
-   Tools, Supplies and Equipment (https://www.painttalk.com/f12/)
-   -   Titan advantage 400 leaking transducer (https://www.painttalk.com/f12/titan-advantage-400-leaking-transducer-95341/)

Masterpiece 12-16-2019 07:03 PM

Titan advantage 400 leaking transducer
 
I haven't found much info yet but my old Titan Advantage 400 has a manual pressure knob with a push button style transducer and it seems to be leaking quite a lot through the small channel machined into the sprayer behind the plastic cover on the front left of the sprayer. Fortunately I'm only running water through it as a test, but aside from the O-ring on the bottom of it that I replaced, I'm not sure where the leak is still coming from or could it be the transducer itself somehow is leaking?

Edit: And by o-ring, I mean the black o-ring that fits on the bottom of the transducer itself where it screws to the sprayer surface. There are also what look to be 2 very tiny washers, 1 on each end of the transducer. I assume they are designed to ensure any fluids only make contact with the transducer 'button'. Perhaps those tiny washers are allowing fluid THROUGH the transducer and out the front of the sprayer.

MikeCalifornia 12-16-2019 10:00 PM

Your sprayer, I don't believe has a transducer, only the 440i and up models. You most likely just need a repack kit, with a possible piston too.

cocomonkeynuts 12-16-2019 10:56 PM

Quote:

Originally Posted by MikeCalifornia (Post 1673119)
Your sprayer, I don't believe has a transducer, only the 440i and up models. You most likely just need a repack kit, with a possible piston too.


the advantage 400 does have a "transducer", which looks like just a mechanical pressure control valve. page 10.
https://cdn.shopify.com/s/files/1/12...30293609759164
https://www.painthose.com/titan-0551...-assembly-oem/





my guess would be packing's or rod as well. Don't know enough about titan pumps to say more without seeing it.

Masterpiece 12-16-2019 11:41 PM

That's what I'm unsure of. Because with the front cover off, I can watch the piston while the sprayer runs and there is no fluid coming from the top packing/around the top of the piston. Unless perhaps the upper bottom packing (there are 2 bottom packings stacked together) has torn allowing fluid to escape below the top packing. May need to tear down and inspect the T block internal design

cocomonkeynuts 12-17-2019 09:27 AM

Quote:

Originally Posted by Masterpiece (Post 1673129)
That's what I'm unsure of. Because with the front cover off, I can watch the piston while the sprayer runs and there is no fluid coming from the top packing/around the top of the piston. Unless perhaps the upper bottom packing (there are 2 bottom packings stacked together) has torn allowing fluid to escape below the top packing. May need to tear down and inspect the T block internal design


It is possible the pressure control valve needs replacing...

Masterpiece 12-23-2019 10:52 AM

Just an update, I finally received the mechanical pressure transducer and installed it and it fixed the leak.

I had replaced the lower o-ring on the original (10+ year old) transducer but it didn't change anything, replacing it was the fix.

Thanks for the input guys,

Jeremy


All times are GMT -4. The time now is 01:00 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.