Graco 390 issue - Paint Talk - Professional Painting Contractors Forum
CLICK HERE AND JOIN OUR COMMUNITY TODAY, IT'S FREE!
Go Back   Paint Talk - Professional Painting Contractors Forum > Painting Forum > General Painting Discussion

Reply
 
Thread Tools Display Modes
Old 02-14-2015, 06:20 PM   #1
Senior Member
 
Join Date: Oct 2007
Posts: 112
Rewards Points: 89
Thanks: 49
Thanked 18 Times in 14 Posts
View ogre's Photo Album My Photos
Default Graco 390 issue

My 390 nova primer valve does not turn to prime. I feel like if i put any more pressure on it the knob might break. Before i break the whole manifold down, does anyone have experience with this issue?
ogre is offline   Reply With Quote

Warning: The topics covered on this site include activities in which there exists the potential for serious injury or death. PaintTalk.com DOES NOT guarantee the accuracy or completeness of any information contained on this site. Always use proper safety precaution and reference reliable outside sources before attempting any construction or remodeling task!

Sponsored Links
Advertisement
 
Old 02-14-2015, 11:30 PM   #2
Troy
 
stelzerpaintinginc.'s Avatar
 
Join Date: May 2012
Location: Portland, OR
Posts: 1,903
Rewards Points: 134
Thanks: 2,041
Thanked 2,553 Times in 1,122 Posts
View stelzerpaintinginc.'s Photo Album My Photos
Default

Quote:
Originally Posted by ogre View Post
My 390 nova primer valve does not turn to prime. I feel like if i put any more pressure on it the knob might break. Before i break the whole manifold down, does anyone have experience with this issue?

Try turning it in the opposite direction.
__________________
Troy Stevens, Stelzer Painting Inc.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
stelzerpaintinginc. is online now   Reply With Quote
The Following User Says Thank You to stelzerpaintinginc. For This Useful Post:
Repaintpro (02-14-2015)
Old 02-15-2015, 10:14 AM   #3
Senior Member
 
Bender's Avatar
 
Join Date: Aug 2008
Location: Nampa, ID
Posts: 5,354
Rewards Points: 8
Thanks: 5,842
Thanked 3,481 Times in 1,798 Posts
View Bender's Photo Album My Photos
Default

I rarely use the primer on my pumps. Is this common or do you always use it?
__________________
How fortunate we are!

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Bender is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-15-2015, 12:24 PM   #4
Junior Member
 
Join Date: Feb 2015
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
View paint guy 71's Photo Album My Photos
Default

You should prime every time, it's easier on your pump. If you are still having issues, remove all pressure, and remove and clean or replace the prime valve. Removing the pin from the handle is the hardest part.
paint guy 71 is offline   Reply With Quote
Old 02-15-2015, 04:32 PM   #5
Senior Member
 
mr.fixit's Avatar
 
Join Date: Aug 2009
Location: Braintree, Massachusetts
Posts: 1,372
Rewards Points: 570
Thanks: 49
Thanked 481 Times in 289 Posts
View mr.fixit's Photo Album My Photos
Default

Hi Ogre. remove the prime valve it is clogged. I use a finish nail to remove the pin.

cut the finish nail ( cut the pointed end) about an inch and a half put the cut end into the opening in the prime knob and tap the pin out half way. then remove the pin and the finish nail. remove the knob base then unscrew the prime valve ( 13/16 wrench) then disassemble the prime valve ( 11/16) wrench clean , then reassemble. that should solve the problem
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
mr.fixit is offline   Reply With Quote
The Following 3 Users Say Thank You to mr.fixit For This Useful Post:
cardwizzard (02-15-2015), Krittterkare (02-17-2015), ogre (02-15-2015)
Old 02-24-2015, 03:40 PM   #6
Senior Member
 
Join Date: Jan 2014
Location: CT, NY, NJ, MN
Posts: 136
Rewards Points: 197
Thanks: 1
Thanked 103 Times in 65 Posts
View SprayRepairGuy's Photo Album My Photos
Default

Parts Breakdown...
Attached Thumbnails
Graco 390 issue-2-24-2015-3-38-34-pm.jpg  

SprayRepairGuy is offline   Reply With Quote
The Following 3 Users Say Thank You to SprayRepairGuy For This Useful Post:
Bender (02-24-2015), DennisNYS (02-24-2015), ogre (02-24-2015)
Reply

Tags
None

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Graco 390 Camaro Tools, Supplies and Equipment 8 08-24-2014 02:36 AM
Nova / Graco 390 Edrick Tools, Supplies and Equipment 9 03-02-2014 08:03 PM
Graco 170 or 390 MDO Tools, Supplies and Equipment 6 03-17-2012 09:19 PM
Graco 390 Bigboypainting Tools, Supplies and Equipment 19 06-07-2011 10:19 PM
graco 390 advice dtree Tools, Supplies and Equipment 19 12-21-2010 08:01 AM


All times are GMT -4. The time now is 07:14 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Our Pro Sites Network
ContractorTalk.com | DrywallTalk.com | ElectricianTalk.com | HVACSite.com | PlumbingZone.com | RoofingTalk.com