Professional Painting Contractors Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Not broken, it is new and it was working fine one minute and the next it sprayed a small amount of paint even when the trigger was off. Maybe dirt in there? Make needle not seat perfectly. It was after an extended use and lots of dried paint all over it. ?? I just am hoping to find out if there is an easy explanation.
 

· PaInTeR ExTrAoRdInAiRe
Joined
·
4,509 Posts
Not broken, it is new and it was working fine one minute and the next it sprayed a small amount of paint even when the trigger was off. Maybe dirt in there? Make needle not seat perfectly. It was after an extended use and lots of dried paint all over it. ?? I just am hoping to find out if there is an easy explanation.
Remove the diffusser and see if something is there. ;)
 

· Registered
Joined
·
236 Posts
Not broken, it is new and it was working fine one minute and the next it sprayed a small amount of paint even when the trigger was off. Maybe dirt in there? Make needle not seat perfectly. It was after an extended use and lots of dried paint all over it. ?? I just am hoping to find out if there is an easy explanation.
strain your paint sometimes I double strain it.
packing nut to tight and or needs a drop of oil (lubrication) for needle to slide back and forth.
beside what you already know and what has been said.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top