Professional Painting Contractors Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hello,

I am using a Titan 440i sprayer for an interior project. In operating the sprayer, I am getting a poor spray patter. The paint is being applied normally within the interior of the spray pattern, however the outer edges of the pattern are thicker and cause streaks. I am back-rolling, however it is causing me to go back and re-spray some areas for a cleaner look. I have tried two different spray tips (419 and 317) and have seen the same patter from both. The paint I am using is Sherwin Williams Superpaint, Flat sheen, and Latex base. If anyone has any ideas on how to correct the problem, I would greatly appreciate it!
 

·
Go Cardinals!!!
Joined
·
145 Posts
Same thing I was thinkin:yes:
 

·
.
Joined
·
17,849 Posts
I agree with turn your pressure up.
Also if you are using an old gaurd that can cause fingering.
When was the last time it was repacked?
Are you using to much hose?
Could there be a chunk of paint in either the manifold filter, or at the inlet strainer?
Are you running cheap and/or thin cord?
 

·
FT painter/FT dad
Joined
·
1,254 Posts
pressure up
check tips
check filters
strain paint well

that's all I got
 

·
Registered
Joined
·
745 Posts
all the above is right on correct !
... and x19, x17 ???? try x15

thin your product 5 - 10% to get through this job, then pack the pump.
r
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #8 ·
Thanks

Thanks for the help guys. I have tried changing the pressure and the tips, so I think I probably need to repack the pump and get a new filter for the gun. I did find the paint comment humorous! :thumbup:
 
1 - 10 of 10 Posts
Top