Professional Painting Contractors Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
hey folks. i have a 5 year old Titan 440 sprayer that just runs now, and doesnt build up pressure. i tired joggling the bearing valve under the intake hose in case it was stuck but that didnt help. a friend said it needed new packings. it looks like item #639-916 from Home Depot is a kit for that. i thought i would ask first before i spent the $40. i have cleaned the prime valve, blown through and cleaned both the intake hose and the sprayer hose. i disaasembled the intake area down past the ball valve and just short of figuring out how to drop the piston assembly. any advice appreciated.

symptom is : put the intake into any liquid, switch on prime and prime. turn prime switch off dial up pressure. pump just runs continuously, if i pull the trigger very very weak pressure.
 

· Registered
Joined
·
1,372 Posts
if it is a 440i he didi not buy it at Home Depot or Lowes. the packing kit for a 440i is Titan p/n 730-401. remove the suction tube and be sure that the inlet ball is not stuck or that there is no debris in it keeping it from sitting flush on the seat. then remove the foot valve and look up into the pump to check the ball in the piston rod. if both balls are free and moving chance are a repack is needed. you can also have a prime issue if the prime valve is clogged
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top