Professional Painting Contractors Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
We have a Titan 740ix and we have cleaned it thoroughly and changed all the filters. instead of a steady stream of fluid it pulses. It also appears to have low pressure. Any ideas on what the problem might be and how to repair it?
 

·
Paint Store Owner
Joined
·
5,550 Posts
Could potentially be a couple things. If its low pressure, that's most likely the pressure sensor. Sporadic "pulsing" or pressure fluctuations, almost like a misfire could be a damaged ball or seat. Depending if its on the up or down stroke would indicate which one. Also could be worn packings causing the pressure fluctuations, but check the balls and seats first.
 

·
Registered
Joined
·
1,372 Posts
as Andy said. if your piston continually moves lower the pressure control until the piston barely moves and watch what way if drifts. if it drifts down you have an intake seat or ball issue ( in the foot valve) problem and if it drifts up you have an outlet seat or ball issue ( piston ball). If all of that is ok you may have a transducer issue
 

·
.
Joined
·
17,849 Posts
as Andy said. if your piston continually moves lower the pressure control until the piston barely moves and watch what way if drifts. if it drifts down you have an intake seat or ball issue ( in the foot valve) problem and if it drifts up you have an outlet seat or ball issue ( piston ball). If all of that is ok you may have a transducer issue
Glad to see you are up and running again. How is the recovery going?
 
1 - 4 of 4 Posts
Top